Echelon Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Has anyone had issues with the resistance buttons not working on the Row? I have a brand new machine and it worked for 1 month. I have been trying to resolve the issue with Echelon for almost two months now without success. I have changed out the controller with a new one and still not working. Thoughts?
 

·
Registered
Joined
·
57 Posts
Welcome @Daedalus. Can you try steps?

If you have just received the rower and your resistance is not changing, please be sure to check the back of the handlebar to remove the white tag and enable resistance.

If resistance is still not working try the steps below to re-pair the controller:



mceclip3.png




mceclip2.png
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Has anyone had issues with the resistance buttons not working on the Row? I have a brand new machine and it worked for 1 month. I have been trying to resolve the issue with Echelon for almost two months now without success. I have changed out the controller with a new one and still not working. Thoughts?
Hi Brent, thanks for reaching out. When I received my new controller, it did not come with any instructions. I had no idea that you had to reset the controller by holding the buttons for 30 seconds. I will give it a try and let you know if it works.
 

·
Registered
Joined
·
21 Posts
What is going on with Echelon's resistance buttons?! People have had issues with the bikes and now the rower? This is nuts.

 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
So, the only thing that I had not tried when I received a new resistance controller was to push both buttons in simultaneously for 30 seconds to reset he controller. This did not work so I am back to square one.
 
1 - 5 of 5 Posts
Top