Echelon Forum banner
1 - 1 of 1 Posts

· Registered
1 Posts
Discussion Starter · #1 ·
I have an Echelon EX5 bike bought about one year ago. It works fine with an iPhone 6s or a Samsung Galaxy S8+. But when I tried to change to a relative newer iPhone (X or Xs) or an iPad, the bike cannot establish a connection with the device. When I launched the app, I could hear a connecting beep, then I would see a red banner on top of the screen "disconnected, tap here to reconnect", then I went through the process to reconnect, but the red banner just kept popping up. I also tried on my iPad, the same thing. The weird thing is that this iPad worked fine with the bike before the summer 2021. I have been e-mailing back and forth with the Echelon technical support team since the beginning of December, but they don't have any solution. I am just curious if anyone else also have the same problem or have a solution. Thanks!
1 - 1 of 1 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.