Echelon Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Wondering if anyone has had the same issue as me. My resistance knob On an ex3 stopped working so I checked all the wires etc and discovered that when I push the brake down towards me the resistance will adjust but not in its normal position. I assume therefore its mechanical- wondering if anyone has a fix? It’s still under warranty but no idea hoW long it would take to fix as am in the UK.
 

·
Registered
Joined
·
78 Posts
Wondering if anyone has had the same issue as me. My resistance knob On an ex3 stopped working so I checked all the wires etc and discovered that when I push the brake down towards me the resistance will adjust but not in its normal position. I assume therefore its mechanical- wondering if anyone has a fix? It’s still under warranty but no idea hoW long it would take to fix as am in the UK.
If it's a mechanical issue you might want to reach out to Echelon and see what can be done.

You're not the only one dealing with resistance issues.

 

·
Registered
Joined
·
2 Posts
running into the same issue. Seems like the knob is just lose all of a sudden and it’s not tightening up the resistance. Been on calls with support, they are usually pretty slow to respond for replacement info but it’s only been a few days.

If it's a mechanical issue you might want to reach out to Echelon and see what can be done.

You're not the only one dealing with resistance issues.

 

·
Registered
Joined
·
78 Posts
running into the same issue. Seems like the knob is just lose all of a sudden and it’s not tightening up the resistance. Been on calls with support, they are usually pretty slow to respond for replacement info but it’s only been a few days.
Welcome to the forum @kash! Have you received any replacement info from Echelon or are you still waiting?
 

·
Registered
Joined
·
2 Posts
Thanks for the welcome.
I got a email yesterday that they are sending me a encoder wheel. I’m not sure what that is but I googled around a bit and it seems that it’s a circuit board in the resistance knob that needs to be replaced.
While I don’t have proof, my guess is someone in the warranty department wanted to try this first before replacing the bike.
Not sure if this sounds familiar to anyone ?
 

·
Registered
Joined
·
4 Posts
running into the same issue. Seems like the knob is just lose all of a sudden and it’s not tightening up the resistance. Been on calls with support, they are usually pretty slow to respond for replacement info but it’s only been a few days.
My bike did the same, just after the warranty expired and an app update. I've been waiting a month for the supervisor to get back to me. It apparently it's the encoder Wheel, which is like $60 CAD for a $20usd part...
 

·
Registered
Joined
·
25 Posts
My resistance knob stopped working in the last week, i updated the firmware last night and now the resistance is backwards. turn left to increase and right to decrease and the speed it goes up and down also seems backwards, ie it's easier to increase then decrease
 
1 - 8 of 8 Posts
Top