Echelon Forum banner
1 - 3 of 3 Posts

· Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hello, so I am new to this bike. I have an EX4S+, I tried a 20 minute climb session and the resistance would auto fluctuate between vey difficult to easy, the display says 32 as the resistance and does not change when the resistance drops? Is this feature of some of the video workouts? Also, cannot pair my galaxy buds 2 to the bike, any help would be appreciated.
 

· Registered
Joined
·
3 Posts
Just got this bike the other day at Costco. Is there a blue light on the front of your handle bars that lights up for the bluetooth to be connected? Mine doesn't light up since I got it three days ago however during a ride today it lit up and my resistance went up and down. After 20 seconds the light went off. I pretty sure its supposed to be on all the time.

I was able to connect my galaxy buds2 pro to the bike. I had to make sure they were not connected to anything first. Turned bluetooth off on my phone, shut down my computer. Put the earbuds back in the case for 20 seconds. Opened the case up which puts them into pairing mode. They showed up on the screen, clicked them to connect. Once connected I then put the earbuds in my ears.
 

· Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
Thanks, yes the light should be on, I had connection issues when I first started, but been very good since, FYI my resistance issue has gone, so just had to reboot. Enjoy the bike, I really do ❤ mine !
 
1 - 3 of 3 Posts
Top