Echelon Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hey everyone. I got the EX5 bike around a mont ago and got tiem spin shoes with spd 56 cleats. I am telling you these shoes will not clip in so I called echelon and they sent me new pedals. The new pedals came and put them on and could only get one shoe on. So I called again and they are sending another pair of pedals. I don’t know what I’m going to do if this shirt pair do not clip in. I’m just so disappointed for spending this much money and can’t even use the bike the way I wanted to. Does anyone have any tips on getting the cleats to clip in to the pedals would great appreciate it!
 

·
Registered
Joined
·
4 Posts
You can loosen the clips (I'm assuming you tried this) with an allen key - but only so far

I believe they had a bad batch of pedals where the tension spring (controls clip in) where there was no hope in hell - and you couldn't actually loosen them

This happened to me also with an EX5 received last month.
The EX5 in my case was replacing a bike I had with issues and so I swapped the pedals - The problem you are experiencing is not normal.

Also note - the crankshafts are standard so you should be able to get any clip in pedals and go.. I'm not a big fan of the echelon pedals - but it is nice how they give the clip/no clip option.

Hope you get clipped in and going soon!
 

·
Registered
Joined
·
1 Posts
Hey everyone. I got the EX5 bike around a mont ago and got tiem spin shoes with spd 56 cleats. I am telling you these shoes will not clip in so I called echelon and they sent me new pedals. The new pedals came and put them on and could only get one shoe on. So I called again and they are sending another pair of pedals. I don’t know what I’m going to do if this shirt pair do not clip in. I’m just so disappointed for spending this much money and can’t even use the bike the way I wanted to. Does anyone have any tips on getting the cleats to clip in to the pedals would great appreciate it!
I am having the exact same issue. First I had to send a picture of my shoes then a video showing me trying to clip in my shoes. They decided to send me a new set of clip; exact same clips I had. I called again and the sent me new pedals. Those don’t work either. Very disappointed.
 

·
Registered
Joined
·
4 Posts
That is very frustrating.

Any idea what is wrong? Is the tension just too high? Did you try adjusting the tension with an allen key?

To get this straight.. do you have their shoes?

First they sent you new clips, the piece that attaches to the shoes.. didn't fix the problem
(not surprising)

Then they sent you knew pedal and that was no better.

Are you experienced with clip ins? They do take a bit of time to get use to.

My guess is the tension spring is too tight for You.

It now is their pedals and their clips correct? So i would have to expect them to mate.

A suggested solution i have is take the shoes to a bike shop and get new pedals. Now i recognize you should not have to pay for pedals, but they will be an upgrade anyway imo (unless you need the toe cage for another rider)
 
1 - 4 of 4 Posts
Top