Echelon Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
We are having some trouble with our pedals. After reading through the forums, it appears that this could be one of 3 problems and I was looking for some help from the community to figure out which it is. Pictures are attached for reference.

1. Pedal clips are installed backwards
2. Pedal clips are installed correctly, spring is just very, very tight so hard to clip into
3. We were given the wrong pedals and they are not SPD compatible

We recently purchased a Echelon EX-5S which was supposed to come standard with SPD compatible, clip-in pedals.

Thanks in advance!
36

35
 

·
Registered
Joined
·
2 Posts
Hi - I just purchased the same bike and am new to ALL of this! Pedal looks like mine. I bought Tiem’s at REI and they installed the cleats for me - clip in and out fine.
 

·
Registered
Joined
·
2 Posts
Hi - I just purchased the same bike and am new to ALL of this! Pedal looks like mine. I bought Tiem’s at REI and they installed the cleats for me - clip in and out fine.

7161B6FA-CC17-4C59-9C47-36A334572724.jpeg
 

·
Registered
Joined
·
5 Posts
We are having some trouble with our pedals. After reading through the forums, it appears that this could be one of 3 problems and I was looking for some help from the community to figure out which it is. Pictures are attached for reference.

1. Pedal clips are installed backwards
2. Pedal clips are installed correctly, spring is just very, very tight so hard to clip into
3. We were given the wrong pedals and they are not SPD compatible

We recently purchased a Echelon EX-5S which was supposed to come standard with SPD compatible, clip-in pedals.

Thanks in advance!
View attachment 36
View attachment 35
I don’t know if you found my earlier post, but I think it applies to you too.

 

·
Registered
Joined
·
19 Posts
We are having some trouble with our pedals. After reading through the forums, it appears that this could be one of 3 problems and I was looking for some help from the community to figure out which it is. Pictures are attached for reference.

1. Pedal clips are installed backwards
2. Pedal clips are installed correctly, spring is just very, very tight so hard to clip into
3. We were given the wrong pedals and they are not SPD compatible

We recently purchased a Echelon EX-5S which was supposed to come standard with SPD compatible, clip-in pedals.

Thanks in advance!
View attachment 36
View attachment 35
the issue was the wrong cleats.
echelon never specified on their site!

just got off the chat with Echelon. I guess these pedals are only compatible with SH56 cleats. Really wish they will disclose this really crucial information on their product description so it won’t have everyone confused/frustrated.
 
1 - 5 of 5 Posts
Top